May 24, 2017, 08:38:13 AM

Author Topic: extreme lags  (Read 1296 times)

McPhisto2051

  • Newbie
  • *
  • Posts: 37
    • View Profile
extreme lags
« on: July 02, 2016, 01:33:19 AM »
hey everyone...
i looove this game but when i reached year 8 it started lagging so damn its nearly impossible to play. even clicking on the buttons is almost impossible and takes over 20 secs each...
no gnome is stuck and there are paths everywhere (no wall ins or sth)
what could be the reason 4 it?

Kazinn

  • Jr. Member
  • **
  • Posts: 59
    • View Profile
Re: extreme lags
« Reply #1 on: July 02, 2016, 05:21:32 AM »
Beetles may be a reason (during one of my fights, i killed 2000 beetles, the computer doesn't like this), or if you remove the floor at -100 (or -101?) till you reach the lava level, you can say byebye to your game.
Stucked gnomes too may provide lag.

Thaarael

  • Newbie
  • *
  • Posts: 39
    • View Profile
Re: extreme lags
« Reply #2 on: July 02, 2016, 01:03:28 PM »
Lag may be as well caused by gnomes constantly moving fast over not-completly lit areas, especially if there are holes, ravines or other multi-level exposures. Lightning engine doesn't go well with constant updating light level in such places, and even shade on wall in corridors with high traffic may result in massive lag; I have experienced it in many worlds, and best solution is to avoid it is to seal floors in caves and keep areas overlit. Making shortcuts may help too, so AI won't need to calculate pathes over entire map. From the other hand, if that didn't help, it means you have beetles and only solution here is to exterminate them all.

McPhisto2051

  • Newbie
  • *
  • Posts: 37
    • View Profile
Re: extreme lags
« Reply #3 on: July 03, 2016, 10:05:52 AM »
as i originally said: no gnome is stuck  ;D
im just at layer 50 something so there should be no lava, everything is well litten and i have never seen a beetle in the whole game. but i dont open paths down because im afraid of intruding monsters ^^

is there a way 2 check if there are many beetles somewhere or massive amounts of other creep? (even if its cheated i just wanna play without the massive lags)
« Last Edit: July 03, 2016, 10:08:14 AM by McPhisto2051 »

Thaarael

  • Newbie
  • *
  • Posts: 39
    • View Profile
Re: extreme lags
« Reply #4 on: July 04, 2016, 01:53:33 PM »
You can use Gnomoria Save Game Editor (GSGE) from pinned post in Addons section to reveal entire map, and manually search it. Not sure about other sollutions (you could search save game editors, maybe one have implemented option to remove enemies, but I am not sure about that, was never messing with this stuff).

McPhisto2051

  • Newbie
  • *
  • Posts: 37
    • View Profile
Re: extreme lags
« Reply #5 on: July 23, 2016, 01:35:05 AM »
looks like the GSGE is just for the 0.9x version of gnomoria it crashes while starting it  :-\ (if reinstalling the pc doesnt help)

Nordiii

  • Newbie
  • *
  • Posts: 4
    • View Profile
Re: extreme lags
« Reply #6 on: July 23, 2016, 10:18:54 AM »
Maybe try this version:
http://forums.gnomoria.com/index.php?topic=8278.75

The version on the first page should work to but not 100% sure

McPhisto2051

  • Newbie
  • *
  • Posts: 37
    • View Profile
Re: extreme lags
« Reply #7 on: July 24, 2016, 01:53:11 AM »
it starts and loads the game (after 6-8 mins or so (like the original game does))
there are 6 zombies und 2 skeletons which i didnt find ingame but i cant remove them, just edit their stats  :-\
if i try to fix all ghost items it crashes too  >:(