November 21, 2017, 01:15:14 PM

Recent Posts

Pages: 1 ... 8 9 [10]
91
Addons / Textures / Re: How to use mods? Steam Workshop
« Last post by Tharis on January 19, 2017, 02:33:22 AM »
Sorry for Necro posting this however I have the same issue.

I followed Tacyn's instructions:

To use the mod select 'New Game'-> Advanced Setup -> Select Mods.
Then choose 'Tacyn's Base Mod v1.8' from the list next to 'Base Mod'.
Afterwards select 'back' and 'Generate' to begin.

Once I choose the base mod and hit back it goes back to the advanced setup screen as normal I hit generate and it crashes the game. Now I figure this is because the mod pack, as is currently available, has some conflicting mods inside it; such as certain features on or off and both are included in the pack.  Here is the issue with this... Since there are no mods in the available mods field as is the same issue that toothface originally posted, I cannot select which features I'd like to have active and which I do not want active. But the instructions for loading this mod were so simple that it doesn't answer the question why I'm not seeing any mods from within the pack to select in the first place.

I won't lie I didn't want to post this because I feel incredibly stupid that I cannot get it to work and do not want to bother people with such a dumb question, but I see no alternative. Is there some step I'm missing? Do I need to unpack something before I hop into the game client and select the mod? I'm unsure because there are no instructions for this just Pick the base mod and generate... which doesn't work.
92
Support / Re: Game Crash
« Last post by admanter on January 17, 2017, 05:19:13 AM »
Are you running mods?

Did you remove or update any of them?

Can you upload your world and say at what time it crashes?

This looks like some kind of hauling error, a gnome putting things away maybe. You might have to take everyone's profession off(or take hauling off all professions) until you can find the problem.

If its a glitched container you might need to just isolate it away from all gnomes,(build a dirt box around it).
93
Support / Game Crash
« Last post by Xenathe on January 15, 2017, 03:25:05 AM »
The game crashes at the same point every time I load it. I have tried stopping all work to no avail. Not sure I'm doing this right but here is the crash log as far as I can tell.



at A.cebc1c67c4a164a49b1c279b0006957be.c49a93168dc3d77742f5742786a5b60b9(String[] c51864dddd6353b79e1a34e131a62f09a)
////////////////////////////////////////////////////////////////

////////////////////////////////////////////////////////////////
    Date: 1/15/2017 3:13:34 AM
Assembly: gnomoria.exe
 Version: 1.0.0.0
   World: world01
 Message: Collection was modified; enumeration operation may not execute.
////////////////////////////////////////////////////////////////
   at System.ThrowHelper.ThrowInvalidOperationException(ExceptionResource resource)
   at System.Collections.Generic.List`1.Enumerator.MoveNextRare()
   at System.Collections.Generic.List`1.Enumerator.MoveNext()
   at Game.GameEntityManager.c888bc36af8719ea94bfb1f01dc886761()
   at Game.GameEntityManager.Update(Single dt)
   at Game.GnomanEmpire.cce48101c3be44fa5bd8b6826610afdec(Single c98206223a14c41d705f29e408e0b44cd)
   at Game.GnomanEmpire.Update(GameTime gameTime)
   at Microsoft.Xna.Framework.Game.Tick()
   at Microsoft.Xna.Framework.Game.HostIdle(Object sender, EventArgs e)
   at Microsoft.Xna.Framework.GameHost.OnIdle()
   at Microsoft.Xna.Framework.WindowsGameHost.RunOneFrame()
   at Microsoft.Xna.Framework.WindowsGameHost.ApplicationIdle(Object sender, EventArgs e)
   at System.Windows.Forms.Application.ThreadContext.System.Windows.Forms.UnsafeNativeMethods.IMsoComponent.FDoIdle(Int32 grfidlef)
   at System.Windows.Forms.Application.ComponentManager.System.Windows.Forms.UnsafeNativeMethods.IMsoComponentManager.FPushMessageLoop(IntPtr dwComponentID, Int32 reason, Int32 pvLoopData)
   at System.Windows.Forms.Application.ThreadContext.RunMessageLoopInner(Int32 reason, ApplicationContext context)
   at System.Windows.Forms.Application.ThreadContext.RunMessageLoop(Int32 reason, ApplicationContext context)
   at System.Windows.Forms.Application.Run(Form mainForm)
   at Microsoft.Xna.Framework.WindowsGameHost.Run()
   at Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
   at A.cebc1c67c4a164a49b1c279b0006957be.c49a93168dc3d77742f5742786a5b60b9(String[] c51864dddd6353b79e1a34e131a62f09a)
////////////////////////////////////////////////////////////////

94
Support / Re: Game Crashing During Launch
« Last post by admanter on January 04, 2017, 07:16:11 AM »
Reading the error carefully it looks like its trying to delete the file.
Clearing your temp files may help.

You may need to look up this error in regards to the Microsoft Xna Framework.

I assume you're running windows 10? Try compatibility mode on the application.

If that fails, see if you can find issues and workarounds related to the Xna framework and windows 10.
95
General / Re: RoboB0b's prolonged absence
« Last post by Phtal on December 31, 2016, 02:00:35 PM »
I could not imagine to try to "take Robobobs game". Its his game, we alle bought it and are quite happy with it :)
He shall do whatever he thinks is "his" way of doing things. Hopefully he will remember his fans - and will come back later (TM).
Please stop discuss "buying" his game - as the source is not on sale :P

But ... i can imagine doing some "reverse engineering" and developing a few patches *gg* <runsaway>
96
General / Re: RoboB0b's prolonged absence
« Last post by Asibin on December 30, 2016, 11:07:42 PM »
I would definitely be willing to donate some money to the cause.
97
Addons / Textures / Re: [Tilesheet] Gnomoria Worlds - Support Needed :D
« Last post by bret on December 29, 2016, 12:14:05 PM »
Quote
Likewise! Frankly I'm amazed it hasn't been incorporated into the base game yet!

I agree
98
Support / Game Crashing During Launch
« Last post by Ulta on December 24, 2016, 08:12:30 PM »
Hi,

When I launch the game, the game crashes before the game window appears. Here is the crash log.

Code: [Select]
////////////////////////////////////////////////////////////////
    Date: 12/24/2016 11:01:35 PM
Assembly: Gnomoria.exe
 Version: 1.0.0.0
   World:
 Message: Error loading "Cursors\Horizontal".
////////////////////////////////////////////////////////////////
   at Microsoft.Xna.Framework.Content.ContentReader.ReadAsset[T]()
   at Microsoft.Xna.Framework.Content.ContentManager.ReadAsset[T](String assetName, Action`1 recordDisposableObject)
   at Microsoft.Xna.Framework.Content.ContentManager.Load[T](String assetName)
   at Game.GUI.Controls.Skin.Init()
   at Game.GUI.Controls.Manager.SetSkin(Skin skin)
   at Game.GUI.Controls.Manager.Initialize()
   at Game.GUI.GuiManager.Initialize()
   at Game.GUI.GuiManager..ctor()
   at Game.GnomanEmpire.Initialize()
   at Microsoft.Xna.Framework.Game.RunGame(Boolean useBlockingRun)
   at A.cebc1c67c4a164a49b1c279b0006957be.c49a93168dc3d77742f5742786a5b60b9(String[] c51864dddd6353b79e1a34e131a62f09a)
////////////////////////////////////////////////////////////////

////////////////////////////////////////////////////////////////
    Date: 12/24/2016 11:01:35 PM
Assembly: Gnomoria.exe
 Version: 1.0.0.0
   World:
 Message: The process cannot access the file 'C:\Users\Name\AppData\Local\Temp\tmp8CA.tmp' because it is being used by another process.
////////////////////////////////////////////////////////////////
   at System.IO.__Error.WinIOError(Int32 errorCode, String maybeFullPath)
   at System.IO.File.InternalDelete(String path, Boolean checkHost)
   at System.IO.File.Delete(String path)
   at Game.GUI.Controls.CursorReader.Read(ContentReader input, Cursor existingInstance)
   at Microsoft.Xna.Framework.Content.ContentReader.InvokeReader[T](ContentTypeReader reader, Object existingInstance)
   at Microsoft.Xna.Framework.Content.ContentReader.ReadObjectInternal[T](Object existingInstance)
   at Microsoft.Xna.Framework.Content.ContentReader.ReadObject[T]()
   at Microsoft.Xna.Framework.Content.ContentReader.ReadAsset[T]()
////////////////////////////////////////////////////////////////

They both happen, which leads me to suspect the first is caused by the second. After each time it fails to launch, I check which processes are using the tmp file with tasklist /m and I always end up with nothing. I cannot check before launch since it always uses/generates a random tmp file. My only guess is that it could be something in launch trying to access this file multiple times.

Thanks in advance!
99
General / Re: RoboB0b's prolonged absence
« Last post by daxter on December 19, 2016, 05:23:16 PM »
Just to say I love the idea of buying source-code (if Robobob does not intend to keep updating the game) and improving it. I would definitely contribute with financial support to this endeavor.
Pages: 1 ... 8 9 [10]